summaryrefslogtreecommitdiffstats
path: root/kopete/kopete/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/kopete/CMakeLists.txt')
-rw-r--r--kopete/kopete/CMakeLists.txt22
1 files changed, 19 insertions, 3 deletions
diff --git a/kopete/kopete/CMakeLists.txt b/kopete/kopete/CMakeLists.txt
index 054587cb..ac3cd5aa 100644
--- a/kopete/kopete/CMakeLists.txt
+++ b/kopete/kopete/CMakeLists.txt
@@ -43,9 +43,25 @@ link_directories(
##### other data ################################
tde_install_icons( )
-install( FILES kopete.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES kopeteui.rc eventsrc DESTINATION ${DATA_INSTALL_DIR}/kopete )
-install( FILES x-kopete-emoticons.desktop DESTINATION ${MIME_INSTALL_DIR}/application )
+
+tde_create_translated_desktop(
+ SOURCE kopete.desktop
+ PO_DIR kopete-desktops
+)
+
+install( FILES kopeteui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete )
+
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/kopete
+ PO_DIR kopete-eventsrc
+)
+
+tde_create_translated_desktop(
+ SOURCE x-kopete-emoticons.desktop
+ DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR kopete-desktops
+)
##### kopete (executable) #######################