summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-03-14 00:37:49 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-03-14 00:37:49 +0100
commit4b34cf6bede5edd2537783e64f61511c7e5df755 (patch)
tree706c36aaa2a1aa4687d1478119c882a470089308 /CMakeLists.txt
parent49c43d74d820cae7ce5a7291702bbc5ae1b3bf9e (diff)
downloadkdbg-4b34cf6bede5edd2537783e64f61511c7e5df755.tar.gz
kdbg-4b34cf6bede5edd2537783e64f61511c7e5df755.zip
Update the use of TQRegExp so that it does not require an old API.
The definition of -UTQT_NO_COMPAT is no longer needed. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5543d91..6ceba2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST -UTQT_NO_COMPAT )
+add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )