summaryrefslogtreecommitdiffstats
path: root/kdbg/pics/mng/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdbg/pics/mng/Makefile.am')
-rw-r--r--kdbg/pics/mng/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kdbg/pics/mng/Makefile.am b/kdbg/pics/mng/Makefile.am
new file mode 100644
index 0000000..e195008
--- /dev/null
+++ b/kdbg/pics/mng/Makefile.am
@@ -0,0 +1,19 @@
+animation = $(shell cd "$(srcdir)" && echo hi22-action-pulse0000*.png)
+
+# this requires ImageMagick
+hi22-action-pulse.png: hi22-action-pulse.pngseq
+ list="$(animation)" ; \
+ montage +frame +shadow +label -background black \
+ -geometry 22x22 \
+ -tile 1x`echo $$list | wc -w` \
+ $$list hi22-action-pulse.png
+
+hi22-action-pulse.pngseq: hi22-action-pulse.xml
+ @echo "Using cinelerra render $< into a PNG sequence $@"
+ @echo "If you do not have cinelerra, just touch $@"
+ exit 1
+
+# This file can be rendered by cinelerra into a "PNG sequence".
+# This produces the PNG sequence $(animation), which is pasted together
+# by `make hi22-action-pulse.png'.
+EXTRA_DIST = hi22-action-pulse.xml $(animation)