summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:55:57 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:13:27 +0900
commita1e8a90d872021eb5785652bb0b43273f4d4492c (patch)
tree316602169d21e065c0c6db77bc8cb3bf00bc4faf /CMakeLists.txt
parent5e19ef6f9756a15fc378d38d24c1ae93ceb29ef9 (diff)
downloadkshowmail-a1e8a90d872021eb5785652bb0b43273f4d4492c.tar.gz
kshowmail-a1e8a90d872021eb5785652bb0b43273f4d4492c.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1159e4..a645055 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )