summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:56:54 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:15:44 +0900
commitcb4c5cd75f2943ecd2f599862183baa2f3d0964a (patch)
tree831713d3a52448cc7a65cabfd98038874c7d155b /CMakeLists.txt
parent886ea66603edd907c7337e05c143740a4d5465e1 (diff)
downloadsmb4k-cb4c5cd75f2943ecd2f599862183baa2f3d0964a.tar.gz
smb4k-cb4c5cd75f2943ecd2f599862183baa2f3d0964a.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfc902a..5245a6d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,15 +10,19 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
-#### general package setup
+##### general package setup
project( smb4k )
-#### include essential cmake modules
+##### include essential cmake modules
include( FindPkgConfig )
include( CheckSymbolExists )
@@ -29,16 +33,11 @@ include( CheckCXXSourceCompiles )
include( CheckTypeSize )
-#### include our cmake modules
+##### include our cmake modules
include( TDEMacros )
-##### set version number
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )