summaryrefslogtreecommitdiffstats
path: root/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/CMakeLists.txt')
-rw-r--r--plugin/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/plugin/CMakeLists.txt b/plugin/CMakeLists.txt
new file mode 100644
index 0000000..f2b0ba6
--- /dev/null
+++ b/plugin/CMakeLists.txt
@@ -0,0 +1,30 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+)
+
+
+##### pluginloader
+
+tde_import( konqueror )
+tde_add_kpart( konqsidebar_smb4k AUTOMOC
+ SOURCES smb4k_konqplugin.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdeparts-shared konqsidebarplugin-shared smb4kcore-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other files
+
+tde_create_translated_desktop(
+ SOURCE smb4k_add.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqsidebartng/add
+)