summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-02-19 15:10:31 +0300
committerormorph <roma251078@mail.ru>2024-02-19 15:18:16 +0300
commit45bfe81f2672bb44497721ab498eb74021befe97 (patch)
treed5bc833a89e6cf5cec8e8f47d4e3014134b1baf7
parentb1f9a9de4ceb31b373dac2757ef4067e452500b3 (diff)
downloadtde-packaging-gentoo-45bfe81f2672bb44497721ab498eb74021befe97.tar.gz
tde-packaging-gentoo-45bfe81f2672bb44497721ab498eb74021befe97.zip
Added patch for compatibility with poppler-24.02
Solution to problem TDE/tdegraphics#85 Signed-off-by: ormorph <roma251078@mail.ru>
-rw-r--r--trinity-base/tdegraphics-tdefile-plugins/files/tdegraphics-tdefile-plugins-poppler.patch39
-rw-r--r--trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.0.ebuild4
-rw-r--r--trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.1.ebuild4
3 files changed, 47 insertions, 0 deletions
diff --git a/trinity-base/tdegraphics-tdefile-plugins/files/tdegraphics-tdefile-plugins-poppler.patch b/trinity-base/tdegraphics-tdefile-plugins/files/tdegraphics-tdefile-plugins-poppler.patch
new file mode 100644
index 00000000..ea918e4a
--- /dev/null
+++ b/trinity-base/tdegraphics-tdefile-plugins/files/tdegraphics-tdefile-plugins-poppler.patch
@@ -0,0 +1,39 @@
+--- a/config.h.cmake
++++ b/config.h.cmake
+@@ -1,6 +1,7 @@
+ #cmakedefine VERSION "@VERSION@"
+
+ // poppler-tqt
++#cmakedefine HAVE_POPPLER_2402
+ #cmakedefine HAVE_POPPLER_2203
+ #cmakedefine HAVE_POPPLER_2112
+ #cmakedefine HAVE_POPPLER_2111
+--- a/tdefile-plugins/dependencies/poppler-tqt/ConfigureChecks.cmake
++++ b/tdefile-plugins/dependencies/poppler-tqt/ConfigureChecks.cmake
+@@ -24,7 +24,7 @@ check_cxx_source_compiles("
+ HAVE_POPPLER_030 )
+ tde_restore( CMAKE_REQUIRED_INCLUDES CMAKE_REQUIRED_LIBRARIES )
+
+-foreach( _poppler_ver 0.58 0.64 0.70 0.71 0.72 0.76 0.82 0.83 0.86 21.08 21.11 21.12 22.03 )
++foreach( _poppler_ver 0.58 0.64 0.70 0.71 0.72 0.76 0.82 0.83 0.86 21.08 21.11 21.12 22.03 24.02 )
+ string( REPLACE "." "" _poppler_str "${_poppler_ver}" )
+ if( NOT DEFINED HAVE_POPPLER_${_poppler_str} )
+ message( STATUS "Performing Test HAVE_POPPLER_${_poppler_str}" )
+--- a/tdefile-plugins/dependencies/poppler-tqt/poppler-private.cpp
++++ b/tdefile-plugins/dependencies/poppler-tqt/poppler-private.cpp
+@@ -101,9 +101,15 @@ void DocumentData::addTocChildren( TQDomDocument * docSyn, TQDomNode * parent, O
+
+ // 1. create element using outlineItem's title as tagName
+ TQString name;
++#ifdef HAVE_POPPLER_2402
++ const std::vector<Unicode> &uVec = outlineItem->getTitle();
++ name = unicodeToTQString( uVec.data(), uVec.size() );
++#else
+ CONST_064 Unicode * uniChar = outlineItem->getTitle();
+ int titleLength = outlineItem->getTitleLength();
+ name = unicodeToTQString(uniChar, titleLength);
++#endif
++
+ if ( name.isEmpty() )
+ continue;
+
diff --git a/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.0.ebuild b/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.0.ebuild
index 8612da19..fbde0d66 100644
--- a/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.0.ebuild
+++ b/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.0.ebuild
@@ -21,6 +21,10 @@ DEPEND="
pdf? ( app-text/poppler )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-poppler.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DWITH_TIFF="$(usex tiff)"
diff --git a/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.1.ebuild b/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.1.ebuild
index 8612da19..fbde0d66 100644
--- a/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.1.ebuild
+++ b/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.1.1.ebuild
@@ -21,6 +21,10 @@ DEPEND="
pdf? ( app-text/poppler )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-poppler.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DWITH_TIFF="$(usex tiff)"