summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2024-01-02 01:46:49 +0300
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2024-01-17 22:46:31 +0000
commit66b9980c01415d4fbac29e1ece821fed4bad0860 (patch)
tree4306a14e1d84a5983bc872b212c04280d759262c
parent6cb56f6bcfd90772a61ee930ae615efc2821d3d8 (diff)
downloadtde-packaging-gentoo-66b9980c01415d4fbac29e1ece821fed4bad0860.tar.gz
tde-packaging-gentoo-66b9980c01415d4fbac29e1ece821fed4bad0860.zip
media-gfx/povray: several fixes
- add use and upstream to metadata.xml - EROOT with EAPI=7+ requires explicit slash after - use EPREFIX rather than EROOR for built-in config paths Signed-off-by: Alexander Golubev <fatzer2@gmail.com>
-rw-r--r--media-gfx/povray/metadata.xml6
-rw-r--r--media-gfx/povray/povray-3.7.0.10-r1.ebuild (renamed from media-gfx/povray/povray-3.7.0.10.ebuild)13
2 files changed, 12 insertions, 7 deletions
diff --git a/media-gfx/povray/metadata.xml b/media-gfx/povray/metadata.xml
index 689e1534..77a212ff 100644
--- a/media-gfx/povray/metadata.xml
+++ b/media-gfx/povray/metadata.xml
@@ -5,4 +5,10 @@
<email>team-gentoo@trinitydesktop.org</email>
<name>Trinity Gentoo ebuilds project</name>
</maintainer>
+ <use>
+ <flag name="io-restrictions">POV-Ray's mechanism for control of I/O operations</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">POV-Ray/povray</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-gfx/povray/povray-3.7.0.10.ebuild b/media-gfx/povray/povray-3.7.0.10-r1.ebuild
index c7f8873a..1b1ad3ed 100644
--- a/media-gfx/povray/povray-3.7.0.10.ebuild
+++ b/media-gfx/povray/povray-3.7.0.10-r1.ebuild
@@ -5,7 +5,6 @@ EAPI=8
inherit autotools flag-o-matic virtualx
-
DESCRIPTION="The Persistence of Vision Raytracer"
HOMEPAGE="https://www.povray.org/"
SRC_URI="https://github.com/POV-Ray/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -47,7 +46,7 @@ src_configure() {
# but the code compiles using incorrect [default] paths
# (based on /usr/local...), so povray will not find the system
# config files without the following fix:
- append-cppflags -DPOVLIBDIR=\\\""${EROOT}"usr/share/${PN}\\\" -DPOVCONFDIR=\\\""${EROOT}"etc/${PN}\\\"
+ append-cppflags -DPOVLIBDIR=\\\""${EPREFIX}"/usr/share/${PN}\\\" -DPOVCONFDIR=\\\""${EPREFIX}"/etc/${PN}\\\"
# TODO: Restore OpenEXR if upstream start to support OpenEXR 3/imath
econf \
@@ -78,11 +77,11 @@ pkg_preinst() {
# This way, they can be treated by CONFIG_PROTECT as normal.
local conf_file version_dir
for conf_file in "${ED}"/etc/"${PN}"/*; do
- if [ ! -e "${EROOT}etc/${PN}/${conf_file}" ]; then
- for version_dir in $(echo "${EROOT}"etc/"${PN}"/* | grep "^[0-9]" | sort -rn); do
- if [ -e "${EROOT}etc/${PN}/${version_dir}/${conf_file}" ]; then
- mv "${EROOT}etc/${PN}/${version_dir}/${conf_file}" "${EROOT}etc/${PN}" || die
- elog "Note: ${conf_file} moved from ${EROOT}etc/povray/${version_dir}/ to ${EROOT}etc/povray/"
+ if [ ! -e "${EROOT}/etc/${PN}/${conf_file}" ]; then
+ for version_dir in $(echo "${EROOT}"/etc/"${PN}"/* | grep "^[0-9]" | sort -rn); do
+ if [ -e "${EROOT}/etc/${PN}/${version_dir}/${conf_file}" ]; then
+ mv "${EROOT}/etc/${PN}/${version_dir}/${conf_file}" "${EROOT}/etc/${PN}" || die
+ elog "Note: ${conf_file} moved from ${EROOT}/etc/povray/${version_dir}/ to ${EROOT}/etc/povray/"
break
fi
done