summaryrefslogtreecommitdiffstats
path: root/app-dicts
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-30 23:37:16 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-31 16:35:37 +0000
commit3ad534419b773150d7b483914d241bbf554fbbc5 (patch)
tree27e447393a1efe11addfc9183b5686df61ae6b12 /app-dicts
parenteefc54ceb5ebebce82cc219a74c117781149f1b2 (diff)
downloadtde-packaging-gentoo-3ad534419b773150d7b483914d241bbf554fbbc5.tar.gz
tde-packaging-gentoo-3ad534419b773150d7b483914d241bbf554fbbc5.zip
Live ebuilds: Add `Ispell` ebuild and support to `tdelibs`.
Also: Fix typos and sync with stable. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/ispell-de/Manifest1
-rw-r--r--app-dicts/ispell-de/ispell-de-20161207.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-dicts/ispell-de/Manifest b/app-dicts/ispell-de/Manifest
new file mode 100644
index 00000000..0df8a506
--- /dev/null
+++ b/app-dicts/ispell-de/Manifest
@@ -0,0 +1 @@
+DIST igerman98-20161207.tar.bz2 470207 BLAKE2B 38adf9d9d6f6a5252eb9edd26831f7e808bb6568b18a3af1f89085e5fcb4137dd7c01628b5b0a36eb83f5bdec0fb8a3f97c751f628f5ce0823792ef19f57111d SHA512 62be84ac76fd2a0acc25439aa4c04339e54a1c7a2f619d76e0e01cfb53eeeca263c5cc335e315f9adeee9bab5cc392d4c473ca55cbed371c04c123d6fa2272aa
diff --git a/app-dicts/ispell-de/ispell-de-20161207.ebuild b/app-dicts/ispell-de/ispell-de-20161207.ebuild
new file mode 100644
index 00000000..bc3b0ec2
--- /dev/null
+++ b/app-dicts/ispell-de/ispell-de-20161207.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors and Martin V\"ath
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+RESTRICT="mirror"
+MY_P=igerman98-${PV}
+
+DESCRIPTION="German and Swiss dictionaries for ispell"
+HOMEPAGE="http://j3e.de/ispell/igerman98/"
+SRC_URI="http://j3e.de/ispell/igerman98/dict/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 hppa mips ppc sparc x86"
+
+BDEPEND="app-text/ispell:="
+RDEPEND="${BDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ for lang in de_DE de_AT de_CH; do
+ emake ispell/${lang}{.aff,.hash}
+ done
+}
+
+src_install () {
+ insinto /usr/$(get_libdir)/ispell
+ for lang in de_DE de_AT de_CH; do
+ doins ispell/${lang}{.aff,.hash}
+ done
+
+ dodoc Documentation/*
+ rm -f -- "${ED}/usr/share/doc/${PF}/GPL"*
+}