summaryrefslogtreecommitdiffstats
path: root/x11-libs
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
commit18d39ed9f062321b596258a9137f10b3e93b71e0 (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /x11-libs
parentcd2192fbe2c90ea734db5bc716740b7dded481b6 (diff)
downloadtde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.tar.gz
tde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/tqscintilla/Manifest1
-rw-r--r--x11-libs/tqscintilla/tqscintilla-14.1.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/tqscintilla/Manifest b/x11-libs/tqscintilla/Manifest
index 1cdd518a..f6a66964 100644
--- a/x11-libs/tqscintilla/Manifest
+++ b/x11-libs/tqscintilla/Manifest
@@ -1 +1,2 @@
DIST tqscintilla-trinity-14.1.0.tar.xz 653968 BLAKE2B a666c6fb2f199795e6569e646bb89a04bb85277d50b77d17becf56abae3b06a2cb64212772d80c41e79c2dc95e610bc394111a2d90ff8d5103f89a84750ca77b SHA512 3dda53d4901f54393d45ea186690c5b55ad403c9dcfb1585d119ef34b7aa101228af505e94ed8302c7486dfa3874962a85f00462fe03701093e0efaf30626b10
+DIST tqscintilla-trinity-14.1.1.tar.xz 654132 BLAKE2B ec0d8e5a023db94eb9cddad2db6a44848aa179cf36b28a50b80575c409e1889ad3ab38d8aa90da663d7779da0996a666b2007af8442c75a3b2243e5c98e02ddb SHA512 d54799af4ceca0e864ae9169d7e1ef8cd82c2b1efd543dec6f5e10d20e34f39f80f52d7f433af620d8c929fa762405eb84a469bddb9123544a82a679705d43e8
diff --git a/x11-libs/tqscintilla/tqscintilla-14.1.1.ebuild b/x11-libs/tqscintilla/tqscintilla-14.1.1.ebuild
new file mode 100644
index 00000000..e5b7f661
--- /dev/null
+++ b/x11-libs/tqscintilla/tqscintilla-14.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="tqscintilla"
+
+inherit trinity-base-2
+
+DESCRIPTION="TQt source code editing component based on Scintilla"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+TQBASE="/usr/tqt3"
+
+src_configure() {
+ local mycmakeargs
+ mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}${TQBASE}"
+ -DHTML_INSTALL_DIR="${TDEDIR}/share/doc/tde/HTML"
+ -DBUILD_ALL=ON
+ )
+ trinity-base-2_src_configure
+}