summaryrefslogtreecommitdiffstats
path: root/x11-libs
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-04-30 20:47:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /x11-libs
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/tqscintilla/Manifest1
-rw-r--r--x11-libs/tqscintilla/tqscintilla-14.0.12.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/tqscintilla/Manifest b/x11-libs/tqscintilla/Manifest
index 8e8c4964..9385491c 100644
--- a/x11-libs/tqscintilla/Manifest
+++ b/x11-libs/tqscintilla/Manifest
@@ -1 +1,2 @@
DIST tqscintilla-trinity-14.0.11.tar.xz 652000 BLAKE2B 914673873110fb5e9a70cf086283169c42c9eee738ee71b35d5ca02eedec0dd7b6a6b3f3deadcc230cd294c043fd390a6cc2b327b96ab24861c70eeabb548007 SHA512 17bc7456cae4681be028c2d0a3b5769ece0068082d295b77a631d0a99359ec334cae30a1f801a7a6464a3a985e020e39a30b8d8a04662abff5d37afed3f750bf
+DIST tqscintilla-trinity-14.0.12.tar.xz 654360 BLAKE2B 96306124b2e64c524f1c484708aee367ab617c12ea8ff8b6c2fcd81823dd007be07f80478332a9dd06ecc473d7e61700d3c4996808d3a6cf968500e55f9df445 SHA512 58c702b025d10a1e04f51c0f78ef091dcd22f8ff905e842cc42be5af6bf2d7ac0cd878b26a4191d810735da16571aef2253977cf726f2707983ebae66ba9a98f
diff --git a/x11-libs/tqscintilla/tqscintilla-14.0.12.ebuild b/x11-libs/tqscintilla/tqscintilla-14.0.12.ebuild
new file mode 100644
index 00000000..db381aba
--- /dev/null
+++ b/x11-libs/tqscintilla/tqscintilla-14.0.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="tqscintilla"
+
+inherit trinity-base-2
+
+DESCRIPTION="TQt source code editing component based on Scintilla"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+TQBASE="/usr/tqt3"
+
+src_prepare() {
+ sed -i -e "s|include/tqt|include/tqt ${TQBASE}/include|" "${S}/qt/qscintilla.pro" || die
+ eapply_user
+}
+
+src_configure() {
+ echo 'QMAKE_CXXFLAGS += -std=c++98' >>"designer/designer.pro"
+ echo 'QMAKE_LIBS += -L${S}/lib' >>"designer/designer.pro"
+ pushd qt || die
+ tqmake "DESTDIR=${S}/lib" || die
+ popd
+ pushd designer || die
+ tqmake || die
+ popd
+}
+
+src_compile() {
+ emake -C qt
+ emake -C designer
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}" -C qt install
+ insinto "${TQBASE}/$(get_libdir)"
+ insopts "-m 0755"
+ doins lib/*
+ insinto "${TQBASE}/plugins/designer"
+ doins designer/*.so
+ insopts "-m 0644"
+ insinto "${TQBASE}/include/private"
+ doins include/*.h
+ insinto "${TDEDIR}/share/doc/tde/HTML/en/tqscintilla"
+ doins doc/html/*
+}