summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2022-07-14 13:25:19 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2022-07-14 13:49:58 +0900
commit70f9f58541733859df7fa85c8f4b5ed3f0aa2c94 (patch)
tree57a1642774ce6683d506a7b6c2e1c6808c379a07 /CMakeLists.txt
parent2687ba91a924d92d2564a908d59d557bd04dbf93 (diff)
downloadtdeartwork-70f9f58541733859df7fa85c8f4b5ed3f0aa2c94.tar.gz
tdeartwork-70f9f58541733859df7fa85c8f4b5ed3f0aa2c94.zip
Added man pages for TDE applications.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6bf675cd..b4192574 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,6 +72,7 @@ option( WITH_ARTS "Enable aRts support"
##### user requested modules
option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
option( BUILD_EMOTICONS "Build emoticons" ${BUILD_ALL} )
option( BUILD_ICEWM_THEMES "Build icewm-themes" ${BUILD_ALL} )
option( BUILD_ICON_THEMES "Build icon themes" ${BUILD_ALL} )
@@ -100,6 +101,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### tdenetwork directories
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_EMOTICONS emoticons )
tde_conditional_add_subdirectory( BUILD_ICEWM_THEMES icewm-themes )
tde_conditional_add_subdirectory( BUILD_ICON_THEMES IconThemes )