summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2023-12-25 04:49:57 +0300
committerAlexander Golubev <fatzer2@gmail.com>2023-12-25 04:49:57 +0300
commitf2dbf5b9035e9a4861b7d0ad348f4f86c4caba03 (patch)
tree57a666338a3cdd0934492401777262816dbd3c61 /CMakeLists.txt
parentecd60bc6a5f5181bb5013bea114fae5d8efaab47 (diff)
downloadtdebase-f2dbf5b9035e9a4861b7d0ad348f4f86c4caba03.tar.gz
tdebase-f2dbf5b9035e9a4861b7d0ad348f4f86c4caba03.zip
Make dependency upon libssh optional
Signed-off-by: Alexander Golubev <fatzer2@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36124f6fe..e7ab1d23c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,6 +97,7 @@ option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_SASL "Enable SASL support" ${WITH_ALL_OPTIONS} )
option( WITH_LDAP "Enable LDAP support" ${WITH_ALL_OPTIONS} )
option( WITH_SAMBA "Enable SAMBA support" ${WITH_ALL_OPTIONS} )
+option( WITH_SFTP "Enable SFTP support" ${WITH_ALL_OPTIONS} )
option( WITH_OPENEXR "Enable openexr support" ${WITH_ALL_OPTIONS} )
option( WITH_XCOMPOSITE "Enable xcomposite support" ${WITH_ALL_OPTIONS} )
option( WITH_XCURSOR "Enable xcursor support" ${WITH_ALL_OPTIONS} )
@@ -130,6 +131,7 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
# WITH_SASL affects tdeioslaves(tdeio_ldap tdeio_smtp tdeio_pop3)
# WITH_LDAP affects tdeioslaves(tdeio_ldap)
# WITH_SAMBA affects tdeioslaves(tdeio_samba) kcontrol
+# WITH_SFTP affects tdeioslaves(tdeio_sftp)
# WITH_OPENEXR affects tdeioslaves(thumbnail)
# WITH_XCOMPOSITE affects twin kicker(taskmanager) tdm
# WITH_XCURSOR affects tdeioslaves(thumbnail), kcontrol(input), kdesktop