summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatías Fonzo <selk@dragora.org>2020-01-21 21:56:02 -0300
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-22 23:03:40 +0000
commit8ae17a5d9d77d489a2d16529f16680d31374537e (patch)
treee9637b17830787dcd6fab20ed5ab17486fd7ba60 /CMakeLists.txt
parentaa9b9581a97daa50855d815b6724b9112448c96f (diff)
downloadtdelibs-8ae17a5d9d77d489a2d16529f16680d31374537e.tar.gz
tdelibs-8ae17a5d9d77d489a2d16529f16680d31374537e.zip
Use the correct macros isnan, isinf for libc compatibility
Changes related to this commit: - Clean up #if mess. - Use unconditionally the correct macros isnan, isinf. - Remove redudant macros from the build system. Signed-off-by: Matías Fonzo <selk@dragora.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36a7e80fb..809653a79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -395,10 +395,6 @@ check_function_exists( setgroups HAVE_SETGROUPS )
check_function_exists( setlocale HAVE_SETLOCALE )
check_function_exists( setmntent HAVE_SETMNTENT )
check_function_exists( setpriority HAVE_SETPRIORITY )
-check_function_exists( isnan HAVE_FUNC_ISNAN )
-check_function_exists( _finite HAVE_FUNC__FINITE )
-check_function_exists( finite HAVE_FUNC_FINITE )
-check_function_exists( isinf HAVE_FUNC_ISINF )
check_function_exists( freeaddrinfo HAVE_FREEADDRINFO )
check_function_exists( strtoll HAVE_STRTOLL )
check_function_exists( socket HAVE_SOCKET )