summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:53:38 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:17:16 +0900
commit46ccdf9e0ffc1af0e56867b4f937dfccf24c3be8 (patch)
tree50aa20156b86bb74debbb2803051c61c953cf737 /CMakeLists.txt
parentad541147573eb557cb7096f53ab495f7eee64ba0 (diff)
downloadtdepacman-46ccdf9e0ffc1af0e56867b4f937dfccf24c3be8.tar.gz
tdepacman-46ccdf9e0ffc1af0e56867b4f937dfccf24c3be8.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3aad738..60d494e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )