summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-04-30 23:01:33 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-04-30 23:01:33 +0000
commitf540079925f1aec179debd98163e7b8c5a44adea (patch)
tree50f4b5fcb27ac35481b435833a0bf64d8d475eee /CMakeLists.txt
parentf885de23f90bee27299533ede224535ad6c81c56 (diff)
downloadtdesdk-f540079925f1aec179debd98163e7b8c5a44adea.tar.gz
tdesdk-f540079925f1aec179debd98163e7b8c5a44adea.zip
[kdesdk] cmake support for docs - only handbooks, not man(uals)
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdesdk@1229883 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 169d8388..59ca9ad8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,11 @@ include( TDESetupPaths )
tde_setup_paths( )
-##### optional stuff ############################
-
-# option( WITH_ARTS "Enable aRts support" OFF )
-
-
##### user requested modules ####################
option( BUILD_ALL "Build all" OFF )
option( BUILD_CERVISIA "Build cervisia" ${BUILD_ALL} )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
option( BUILD_KAPPTEMPLATE "Build kapptemplate" ${BUILD_ALL} )
@@ -75,6 +71,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### kdesdk directories ########################
tde_conditional_add_subdirectory( BUILD_CERVISIA cervisia )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_KAPPTEMPLATE kapptemplate )