summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-03-14 00:44:07 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-03-14 00:44:07 +0100
commit627fc0ed620c1942afea9483bfaba794418d0300 (patch)
treef65f3520318efdc38de41835e3cff9c9721d0baf /CMakeLists.txt
parent4b34cf6bede5edd2537783e64f61511c7e5df755 (diff)
downloadkdbg-627fc0ed620c1942afea9483bfaba794418d0300.tar.gz
kdbg-627fc0ed620c1942afea9483bfaba794418d0300.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ceba2e..b236f05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )